Non ci sono commenti al momento

sezione commenti aperta al pubblico
  1. Mauro
    #1 Mauro 8 dicembre, 2015, 17:16

    Ho provato a seguire il tuo mini tutorial ma non son riuscito a far funzionare il mio sito spostato nella nuova cartella.
    Devo dire che è all’interno di un multisito su gandi.net e forse c’è qualche configurazione aggiuntiva che non conosco.
    Dopo lo spostamento dei file, la copia e la modifica su root di index.php e .htaccess il sito resta bianco e anche l’area amministrativa.
    Su di un’altro blog suggerivano di modificare anche .htaccess mettendo la nuova cartella su RewiteBase e RewriteRule… ma anche quello non ha funzionato.

    #BEGIN WordPress

    RewriteEngine On
    RewriteBase /nuovacartella/
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /nuovacartella/index.php [L]

    #END WordPress

    Avevo comunque fatto un backup del DB e quindi son tornato indietro in un attimo .. ma mi spiace perché ci tenevo a capire come spostare WP su cartelle diverse ed evitare gli attacchi di tanti buontemponi!

    Rispondi a questo commento
    • Walter Tosolini
      Walter Tosolini Autore 8 dicembre, 2015, 17:35

      La prima cosa da fare in questi casi è dare un occhio ai log di Apache. Con la schermata bianca non è possibile capire dove stia l’inghippo, con i log invece si ha una indicazione. Ad ogni modo la procedura che ho descritto l’avevo testata passo per passo a gennaio su un WP normale. Se stai usando un Multi con sottocartelle, anziché sottodomini potrebbe esserci qualche problema. Il codice che hai incollato di htaccess potrebbe non essere corretto nell’ultima riga. Dopo RewriteRule tra il punto e la / ci dovrebbe essere uno spazio.

      Rispondi a questo commento

Rispondi